Skocz do zawartości
Dejw

[Rozwiązane] Problem z Fortnite Hits

Rekomendowane odpowiedzi

Hejaa.

 

Posiadam taki oto problem.

 

Wgrałem coda na server oraz parę pluginów raczej niezbyt mieszających w mechanikę samej gry.

Postanowiłem dodać hity z fortneita wyglądają bardzo ciekawie więc proces instalacyjny był bardzo prosty.

Przeciągnąłem wszystkie pliki do odpowiednich katalogów i nic niestety nie działa.

Sprawdziłem też parę innych podobnych pluginów po wgraniu również nie pokazywały otrzymywanych obrażeń w formie tekstu czy też grafiki.

Zacząłem się zastanawiać czy może któryś plugin nie powoduje blokady pokazywania obrażeń... niestety po wyłączeniu praktycznie wszystkich pluginów dodanych przeze mnie(po za sourcebansem) plugin nadal nie działał. Brak logów ani informacji w konsoli użyłem pluginu z tego forum.

Liczę na szybką pomoc pozdrawiam! Może ma ktoś działający zamiennik lub działający ten sam plugin a może trzeba dodać gdzieś dodatkowe cvary.

 

Edit: L 09/05/2019 - 17:46:06: [SM] Unable to load plugin "fortnite_hits.smx": Required extension "Client Preferences" file("clientprefs.ext") not running
Jedyne co znalazłem i tylko raz obecnie się to nie pokazuje

 

Edytowane przez Dejw

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Cytat

 

Pokaż plik database.cfg

Obstawiam że ci brakuje ewentualnie jeszcze sm exts list i sprawdź czy masz clientprefs.ext.so

Edytowane przez szogun

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
"Databases"
{
    "codmod_lvl_sql"
    {
        "driver"        "mysql"
        "host"        "dupa"    // adres bazy mysql
        "database"    "dupa"    // database bazy mysql
        "user"        "dupa"    // login uzytkownika do bazy mysql
        "pass"        "dupa"    // haslo uzytkownika do bazy mysql
    }

"driver_default"        "mysql"

    "sourcebans"
    {
        "driver"            "default"
        "host"                "dupa"
        "database"            "dupa"
        "user"                "dupa"
        "pass"                "dupa"
        //"timeout"            "0"
        "port"            "3306"
    }

}

 

Edytowane przez Dejw

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

No to już wiesz w czym problem, powinieneś sobie poradzić dodaj to co ci podałem.

 

Po za tym twój plik database powinien tak wyglądać https://github.com/alliedmodders/sourcemod/blob/master/configs/databases.cfg
Hej! Skorzystałeś z linku lub pobrałeś załącznik? Uhonoruj naszą pracę poprzez rejestrację na forum i rośnij razem z nami!

Edytowane przez szogun

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

okej zmieniłem plik databases.cfg ale nie wiem gdzie owe pliki dodać

 

"sm exts list i sprawdź czy masz clientprefs.ext.so" gdybyś mógł trochę mnie naprowadzić

 

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
5 minut temu, Dejw napisał:

okej zmieniłem plik databases.cfg ale nie wiem gdzie owe pliki dodać

 

"sm exts list i sprawdź czy masz clientprefs.ext.so" gdybyś mógł trochę mnie naprowadzić

 

wpisz w konsoli serwera "sm exts list" i sprawdź czy clientprefs.ext.so jest załadowane
unknown.png

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

 "Automatic Updater" (1.9.0.6276) by AlliedModders LLC: Updates SourceMod gamedata files
 "Webternet" (1.9.0.6276) by AlliedModders LLC: Extension for interacting with URLs
 "CS Tools" (1.9.0.6276) by AlliedModders LLC: CS extended functionality
 "BinTools" (1.9.0.6276) by AlliedModders LLC: Low-level C/C++ Calling API
 "SDK Tools" (1.9.0.6276) by AlliedModders LLC: Source SDK Tools
 "Regex" (1.9.0.6276) by AlliedModders LLC: Provides regex natives for plugins
 "SDK Hooks" (1.9.0.6276) by AlliedModders LLC: Source SDK Hooks
 "Top Menus" (1.9.0.6276) by AlliedModders: Creates sorted nested menus
 "MySQL-DBI" (1.9.0.6276) by AlliedModders LLC: MySQL driver implementation for DBI
 "SQLite" (1.9.0.6276) by AlliedModders LLC: SQLite Driver

 

 

odpowiedź po wpisaniu

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Teraz, Dejw napisał:

 "Automatic Updater" (1.9.0.6276) by AlliedModders LLC: Updates SourceMod gamedata files
 "Webternet" (1.9.0.6276) by AlliedModders LLC: Extension for interacting with URLs
 "CS Tools" (1.9.0.6276) by AlliedModders LLC: CS extended functionality
 "BinTools" (1.9.0.6276) by AlliedModders LLC: Low-level C/C++ Calling API
 "SDK Tools" (1.9.0.6276) by AlliedModders LLC: Source SDK Tools
 "Regex" (1.9.0.6276) by AlliedModders LLC: Provides regex natives for plugins
 "SDK Hooks" (1.9.0.6276) by AlliedModders LLC: Source SDK Hooks
 "Top Menus" (1.9.0.6276) by AlliedModders: Creates sorted nested menus
 "MySQL-DBI" (1.9.0.6276) by AlliedModders LLC: MySQL driver implementation for DBI
 "SQLite" (1.9.0.6276) by AlliedModders LLC: SQLite Driver

 

 

odpowiedź po wpisaniu

Nie masz żadnego błędu pod tym, że nie jest załadowany ext?
Sprawdź czy clientprefs.ext.so znajduję się w folderze "csgo/addons/sourcemod/extensions"

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

jest. aleee po zmianie pliku bazy daniych nie działa mi klasa na cod modzie

database wygląda tak

 

"Databases"
{
	"driver_default"		"mysql"

	"default"
	{
		"driver"			"default"
		"host"				"localhost"
		"database"			"sourcemod"
		"user"				"root"
		"pass"				""
		//"timeout"			"0"
		//"port"			"0"
	}
	
	"storage-local"
	{
		"driver"			"sqlite"
		"database"			"sourcemod-local"
	}

	"clientprefs"
	{
		"driver"			"sqlite"
		"host"				"localhost"
		"database"			"clientprefs-sqlite"
		"user"				"root"
		"pass"				""
		//"timeout"			"0"
		//"port"			"0"

	"codmod_lvl_sql"
	{
	    "driver"        "mysql"
	    "host"        "..."    // adres bazy mysql
	    "database"    "..."    // database bazy mysql
	    "user"        "..."    // login uzytkownika do bazy mysql
	    "pass"        "..."    // haslo uzytkownika do bazy mysql
	}



	"sourcebans"
	{
		"driver"			"default"
		"host"				"..."
		"database"			"..."
		"user"				"..."
		"pass"				"..."
		//"timeout"			"0"
		"port"			"3306"
	}

}

 

co jest nie tak? ta same dane tylko dodałem to co mi polecono

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
3 minuty temu, Dejw napisał:

    "clientprefs"
    {
        "driver"            "sqlite"
        "host"                "localhost"
        "database"            "clientprefs-sqlite"
        "user"                "root"
        "pass"                ""
        //"timeout"            "0"
        //"port"            "0"

Brakuje ci klamry zamykającej "clientprefs"

Edytowane przez Brum Brum
.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Działa do zamknięcia <3! Dziękuję wszystkim za pomoc!

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach

Wiadomość wygenerowana automatycznie

 

Temat został zamknięty. Powodem jest całkowite rozwiązanie problemu zawartego w temacie.

 

Jeśli się z tym nie zgadzasz, zaraportuj ten post z prośbą o ponowne otwarcie i kontynuację dyskusji.

Udostępnij tę odpowiedź


Odnośnik do odpowiedzi
Udostępnij na innych stronach
Gość
Ten temat został zamknięty. Brak możliwości dodania odpowiedzi.

×
×
  • Dodaj nową pozycję...